Mod vecchie: compatibilità

Sezione dedicata all'Off-Topic in generale. E' vietato lo SPAM
Rispondi
Avatar utente
Festival
Nuovo Utente
Nuovo Utente
Messaggi: 2
Iscritto il: 23/05/2023, 12:14
Link del Forum: nessuno al momento

Mod vecchie: compatibilità

Messaggio da Festival »

Domanda probabilmente banale...
volevo provare in locale il mio vecchio sito trovato rispolverando archivi, ma quando vado per installare anche la "base" della mod usata all'epoca, mi da una serie di errori e non mi fa terminare l'installazione... stessa cosa succede con altre mod sempre dell'epoca...

è possibile che essendosi aggiornato php (ora alla versione 8.qualcosa contro la 5.qualcosa di allora) le mod non siano più compatibili?

ed esiste un modo per farle girare "online"? (in locale probabilmente se si riesce ad installare la versione 5.xxx forse).
Avatar utente
alex75
Amministratore
Amministratore
Messaggi: 6146
Iscritto il: 23/08/2012, 23:45
Link del Forum: www.phpbb-italia.it
Località: Palermo

Re: Mod vecchie: compatibilità

Messaggio da alex75 »

Esattamente! Le vecchie mod erano scritte in un linguaggio php oggi perlopiù deprecato.
Oltre a questo, anche i file di phpBB, hanno subito cambiamenti e le vecchie mod, spesso fanno riferimento a parti di codice non più esistenti, negli attuali file di phpBB.
In fine e non per importanza, oggi si usano le estensioni.
Regolamento Forum
Le nostre guide
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<
Rispondi